API outage due to Upstash overload
Resolved·Full outage

Upstash caching server connection issues due to an overload in the connection proxying system resulted in instability for a subset of databases.

https://status.upstash.com/incidents/pw4q7vh1zc7w

Mon, Aug 18, 2025, 04:42 PM
(1 month ago)
·
Affected components
API
Dashboard
Updates

Resolved

Upstash caching server connection issues due to an overload in the connection proxying system resulted in instability for a subset of databases.

https://status.upstash.com/incidents/pw4q7vh1zc7w

Mon, Aug 18, 2025, 04:42 PM

Investigating

Between 2025-08-18 02:40:25 and 2025-08-18 02:51:03 there was an API outage that's being investigated further.

Mon, Aug 18, 2025, 04:15 PM(26 minutes earlier)